AutoSPInstaller: SharePoint 2013 March 10, 2015 CU (KB2956166)

The AutoSPInstaller tool is not something I’ve written about in the past.  I’m not sure why because its a fantastic tool and I use it on a regular basis.  In general, it is a PowerShell based SharePoint installation tool.  If you are unfamiliar with it, I do recommend you take a look at it here.

I use AutoSPInstaller to build SharePoint farms including the creation of web applications, site collections, installation of PU’s and CU’s, etc.  The beauty of using a scripted approach is its consistent.  If your farm ever burns to the ground, its a way to rebuild it just as it was.

I recently used AutoSPInstaller to build a SharePoint 2013 farm for a client.  We then made the decision to install SharePoint 2013 March 10, 2015 CU.  As with all farm-level modifications I make, I added this CU to the AutoSPInstaller updates directory then ran the installer again.  It ran the CU, psconfig and ensured the farm was in an operational state.  It worked flawlessly!

To accomplish this, download the (3) SharePoint 2013 March 10, 2015 CU installation files from the Microsoft site and place them in the SP\AutoSPInstaller\2013\Updates directory.  You then run the launch script again, on all servers, and the cumulative update will be installed for you.  In addition, the script will run psconfig; so you don’t need to do than manually!

Bob Mixon

Senior SharePoint Solution Architect, Senior Information Architect, 5-year Microsoft SharePoint MVP (2006, 2007, 2008, 2009, 2010). Family man, father, grandfather and cook. You can read my entire profile here.

More Posts - Website

Follow Me:
TwitterLinkedIn

2 thoughts on “AutoSPInstaller: SharePoint 2013 March 10, 2015 CU (KB2956166)”

  1. Good post. Reminded me I needed to patch one of my dev farms.
    Then I discovered my Baseline version of SP1 slipsteam is the older release 1: 15.0.4569.1506 and not the newer release 2: 15.0.4571.1502
    Neither April or March 2015 CUs will apply until the SP1 rel 2 is applied.

  2. Hi Daniel.

    That is correct. Another thing for people to note is; when the 1502 SP1 is installed, there is no need to install March 2013 PU, they can jump right to the March 2015 CU.

    Bob

Leave a Reply

Your email address will not be published. Required fields are marked *